Small EOS demonstrator : cannot write to FST

Hello,
I am currently working on a small EOS demonstrator (which will serve for a “hand-on” session for the Tier2 sites in France). I have a couple of virtual machines, one having the roles of mgm,mq,fst, the other fst only.
When I try to write a file with different methods (xrdcp, eos cp), the file is registered in the namespace but its size is 0 and there are error messages in the FST log:

[…]
200804 14:24:09 time=1596543849.065344 func=open level=INFO logid=656c0a32-d64d-11ea-ada4-fa163ef3196f unit=fst@mavm.in2p3.fr:1095 tid=00007fb1be1dd700 source=XrdFstOfsFile:452 tident=root.15927:51@mavm-1 sec=(null) uid=2 gid=2 name=nobody geo="" fst_path=/data1/00000000/000002ce open-mode=300 create-mode=41a0 layout-name=plain
200804 14:24:09 time=1596543849.065355 func=fileOpen level=INFO logid=656c6f4a-d64d-11ea-b5d1-fa163ef3196f unit=fst@mavm.in2p3.fr:1095 tid=00007fb1be1dd700 source=LocalIo:70 tident= sec= uid=0 gid=0 name= geo="" flags=300, path=/data1/00000000/000002ce
200804 14:24:09 time=1596543849.065430 func=open level=WARN logid=656c0a32-d64d-11ea-ada4-fa163ef3196f unit=fst@mavm.in2p3.fr:1095 tid=00007fb1be1dd700 source=XrdFstOfsFile:487 tident=root.15927:51@mavm-1 sec=(null) uid=2 gid=2 name=nobody geo="" not enough space return recoverable error ENODEV(kXR_FSError)
200804 14:24:09 2111 FstOfs_open: root.15927:51@mavm-1 Unable to open - not enough space ; no such device
[…]

I have not been able to find the cause. SElinux disabled, checked /etc/eos.keytab, vid enable sss, group se default on,…
I am mostly following this doc:
http://eos-docs.web.cern.ch/eos-docs/quickstart/admin/configure.html#setup-fst
Any idea ?
Thanks
JM

Hi JM,

Can you double check that the volume has more than 5 GB of free space? There is this requirement on the fst side which you can modify by using the environment variable in this snippet:
https://gitlab.cern.ch/dss/eos/-/blob/master/fst/storage/Storage.cc#L1038

Cheers,
Elvin

Hi Elvin, Excellent, this is it ! I was not aware of this.
I defined EOS_FS_FULL_SIZE_IN_GB=1 in /etc/sysconfig/eos_env, restarted eos@fst and the eos cp works:

[root@mavm ~]$ eos cp /etc/group /eos/testarea/file.1
[eoscp] group Total 0.00 MB |====================| 100.00 % [0.0 MB/s]
[eos-cp] copied 1/1 files and 803 B in 0.07 seconds with 10.85 kB/s

As well as the xrdcp:

[untel@mavm-1 ~]$ xrdcp -d 1 -v -f /etc/issue xroot://mavm.in2p3.fr//eos/testarea/bidon
Secsss (getKeyTab): Unable to open /etc/eos.keytab; Permission denied
Unable to open keytab file.
[23B/23B][100%][==================================================][23B/s]

Thank you !!!

JM