Recompute_quotanode "Operation expired"


we have a quota node with a large number of files (>25M).
We are unable to recalculate the quota, apparently the time for recompute
exceeds the internal timer in the EOS.
time -p eos -b ns recompute_quotanode /eos/baikalgvd/
error: errc=52 msg="[ERROR] Operation expired"
real 1799.27
user 0.06
sys 0.06
Is there an option to increase the timer?

Hi Valeri,

Despite the error, the operation will finish in the background. This is just the client giving up on receiving a response from the server, but the server will recompute the quota node regardless.

To increase the timeout, setting environment variables XRD_STREAMTIMEOUT=3600 and XRD_REQUESTTIMEOUT=3600 should do the trick.


Hi Georgios,

with those environment variables it finished OK.