MGM very talkative after quarkdb migration

I’m getting a TON of logs like this (~1/second for EVERY fsid). Is this cause for concern? They’re not actually draining so…:

200316 16:25:28 time=1584401128.916629 func=Schedule2Drain level=CRIT logid=FstOfsStorage tid=00007fd0d3fff700 source=Schedule2Drain:441 tident=daemon.26623:573@alicefst00 sec=sss uid=2 gid=2 name=daemon geo="" msg=“old style draining enabled for QDB namespace. Prefetching entire filesystem to minimize impact on performance.”
200316 16:25:28 time=1584401128.917629 func=Schedule2Drain level=INFO logid=FstOfsStorage tid=00007fd0d3fff700 source=Schedule2Drain:352 tident=daemon.26623:573@alicefst00 sec=sss uid=2 gid=2 name=daemon geo="" cmd=schedule2drain fsid=82 freebytes=3222463471616 logid=FstOfsStorage

Hi John,

Indeed, after the switch to QDB it’s good to use the new draining system which has been optimized to work with QDB.

IIRC it’s a parameter in the configuration, I’ll let @esindril comment on the details.


Hi John

It depends on what version you are running. For anything >= 4.6.0 the old drain was removed and there is nothing else you need to do. For < 4.6.0 you need to set the following configuration in you /etc/ to enable the new central draining:

# Enable central draining to be use with Quarkdb namespace
mgmofs.centraldrain true