CERN Accelerating science

MGM nodes not starting up

Hello,
new to EOS, I’m trying to install a proof of concept in a sandbox.
Anyway I am already stuck with the MGM nodes not starting up.

I installed 2 eos servers on CENTOS 7.

eos01.local is MGM MASTER1 and eos02.local is MGM MASTER2

The daemons don’t even start up.

MASTER1 config:

DAEMON_COREFILE_LIMIT=unlimited
LD_PRELOAD=/usr/lib64/libjemalloc.so.1
KRB5RCACHETYPE=none
XRD_ROLES=“mq mgm sync”
EOS_MGM_HOST=eos01.local
EOS_MGM_HOST_TARGET=eos02.local
EOS_INSTANCE_NAME=eoss3df
EOS_AUTOLOAD_CONFIG=default
EOS_BROKER_URL=root://localhost:1097//eos/
EOS_GEOTAG=""
EOS_MGM_MASTER1=eos01.local
EOS_MGM_MASTER2=eos02.local
EOS_MGM_ALIAS=eos.local
EOS_MAIL_CC=“my@cern.ch”
EOS_NOTIFY=“mail -s date +%s-hostname-eos-notify $EOS_MAIL_CC”
EOS_HTTP_THREADPOOL=“epoll”
EOS_HTTP_THREADPOOL_SIZE=16
EOS_HTTP_CONNECTION_MEMORY_LIMIT=4194304
EOS_PSS_PORT=1098
EOS_PSS_MGM=$EOS_MGM_ALIAS:1094
EOS_PSS_PATH=/
EOS_TTY_BROADCAST_LISTEN_LOGFILE="/var/log/eos/mgm/xrdlog.mgm"
EOS_TTY_BROACAST_EGREP="“CRIT|ALERT|EMERG|PROGRESS”"

MASTER2 config:

DAEMON_COREFILE_LIMIT=unlimited
LD_PRELOAD=/usr/lib64/libjemalloc.so.1
KRB5RCACHETYPE=none
XRD_ROLES=“mq mgm sync”
EOS_MGM_HOST=eos02.local
EOS_MGM_HOST_TARGET=eos01.local
EOS_INSTANCE_NAME=eoss3df
EOS_AUTOLOAD_CONFIG=default
EOS_BROKER_URL=root://eos01.local:1097//eos/
EOS_GEOTAG=""
EOS_MGM_MASTER1=eos01.local
EOS_MGM_MASTER2=eos02.local
EOS_MGM_ALIAS=eos.local
EOS_MAIL_CC=“my@cern.ch”
EOS_NOTIFY=“mail -s date +%s-hostname-eos-notify $EOS_MAIL_CC”
EOS_HTTP_THREADPOOL=“epoll”
EOS_HTTP_THREADPOOL_SIZE=16
EOS_HTTP_CONNECTION_MEMORY_LIMIT=4194304
EOS_PSS_PORT=1098
EOS_PSS_MGM=$EOS_MGM_ALIAS:1094
EOS_PSS_PATH=/
EOS_TTY_BROADCAST_LISTEN_LOGFILE="/var/log/eos/mgm/xrdlog.mgm"
EOS_TTY_BROACAST_EGREP="“CRIT|ALERT|EMERG|PROGRESS”"

starting up MGM master:

systemctl start eos@master
systemctl status eos@master

● eos@master.service - EOS Master
Loaded: loaded (/usr/lib/systemd/system/eos@master.service; disabled; vendor preset: disabled)
Active: inactive (dead)

Aug 19 22:52:07 eos01.local systemd[1]: Started EOS Master.
Aug 19 22:54:59 eos01.local systemd[1]: Starting EOS Master…
Aug 19 22:54:59 eos01.local echo[1473]: Configured on localhost as master

starting up MGM slave:

systemctl start eos@slave

● eos@slave.service - EOS Slave
Loaded: loaded (/usr/lib/systemd/system/eos@slave.service; disabled; vendor preset: disabled)
Active: inactive (dead)

Aug 19 22:55:26 eos02.local systemd[1]: Starting EOS Slave…
Aug 19 22:55:26 eos02.local sh[1457]: unlink: cannot unlink ‘/var/eos/eos.mq.master’: No such file or directory
Aug 19 22:55:26 eos02.local sh[1457]: unlink: cannot unlink ‘/var/eos/eos.mgm.rw’: No such file or directory
Aug 19 22:55:26 eos02.local systemd[1]: Started EOS Slave.
Aug 19 22:55:26 eos02.local echo[1465]: Configured on localhost as slave.

no log files in /var/log/eos/mgm/

Any hints ? I am stuck at this point.
Thank you

Hi Riccardo,

Try using this guide here to spawn an eos instance based on the most recent tag 4.8.60 inside Docker containers.
https://eos-docs.web.cern.ch/quickstart/docker_image.html

You can also inspect the eos-docker repository that contains all the configuration steps (scripted) needed to get a fully working EOS instance on your machine.
https://gitlab.cern.ch/eos/eos-docker/

Cheers,
Elvin

ok thanks for the hint