EOS installation broken irreparably?

Hi! So, looking over the example eos_env i noticed in test section that eos_instance is not/should not be a random name (as it is implied) but actually the second directory after the /eos … so i tried to change it to alice (instead of eosalice) on all services … and even if i did not noticed any error, everything is broken. i change it back on both mgm and fst , restarted everything and still de installation is broken … any idea about this? and why would eos be so fragile?
healt and node ls show only this:

[root@mgm bin]# eos health
│hostport                        │  status│
 fst01.spacescience.ro:1095        unknown

│group       │offline used│ online free│  status│
 default.0             0 B          0 B     full
 default.1             0 B          0 B     full
 default.2             0 B          0 B     full
 default.3             0 B          0 B     full

│group       │ free fs│ full fs│contention│                          status│
 default.0           0        1      100 % warning: Less than 4 fs in group
 default.1           0        1      100 % warning: Less than 4 fs in group
 default.2           0        1      100 % warning: Less than 4 fs in group
 default.3           0        1      100 % warning: Less than 4 fs in group

│   min│   avg│   max│ min placement│ critical group│
  100 %  100 %  100 %              0       default.3

[root@mgm bin]# eos node ls
│type      │                        hostport│          geotag│    status│   activated│  txgw│ gw-queued│  gw-ntx│ gw-rate│  heartbeatdelta│ nofs│
 nodesview        fst01.spacescience.ro:1095              ???    unknown           on    off          0      100     2000                ~     4

ups, i forgot to restart again also the quarkdb…
but the question remains : what value should have the EOS_INSTANCE? and where it is used/ what meaning does it have?

Hi Adrian,

The instance name MUST start with “eos” and then some alphanumeric characters. For example “eosalicetest”, “eosaliceme” etc. The rest of the characters after the “eos” prefix are used as the root directory for the instance. This is important since there are some special files and directories created in the /eos/<instance_name>/proc/ and in other locations inside the /eos/<instance_name> subtree that are indispensable for the proper functioning of the instance.

By the looks of your eos node ls command the FST on machine fst1.spacescience.ro is not online and not sending any messages to the MGM. For this you also need the MQ to be properly running.


Hi @esindril ! everything was solved when i got back to eosalice instance name.
It would be great if your explanation in brief form can be added in eos_env.example as a comment…
Should i create an issue on EOS github?
Thank you!

Hi Adrian,

Yes, please feel free, we happily accept pull requests! :wink: