Eos client installation 5.1.x broken

Hi Everyone,

I just wanted to report that since a few days our automated Eos client installation for CentOS 7 started failing.

I was installing version 5.1.21, but had the same issue also with version 5.1.30. Once you try to install the package eos-client you end up with this error

Error: Package: eos-client-5.1.30-1.el7.cern.x86_64 (eos-diopside-testing)
           Requires: eos-protobuf3 >= 3.3
           Available: eos-protobuf3-3.17.3-1.el7.cern.eos.x86_64 (eos-diopside-dep)
               eos-protobuf3 = 3.17.3-1.el7.cern.eos
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I guess this is due to the fact that eos-protobuf3 has been obsoleted by eos-grpc (probably to prepare for version 5.2.0)

# yum install eos-protobuf3
Loaded plugins: fastestmirror, langpacks, tsflags, versionlock
Loading mirror speeds from cached hostfile
 * base: centos.mirror.garr.it
 * extras: centos.mirror.garr.it
 * updates: centos.mirror.garr.it
Package eos-protobuf3 is obsoleted by eos-grpc, trying to install eos-grpc-1.56.1-1.el7.x86_64 instead
Resolving Dependencies
--> Running transaction check
---> Package eos-grpc.x86_64 0:1.56.1-1.el7 will be installed
--> Processing Dependency: gnutls for package: eos-grpc-1.56.1-1.el7.x86_64
--> Processing Dependency: c-ares for package: eos-grpc-1.56.1-1.el7.x86_64
--> Running transaction check
---> Package c-ares.x86_64 0:1.10.0-3.el7_9.1 will be installed
---> Package gnutls.x86_64 0:3.3.29-9.el7_6 will be installed
--> Processing Dependency: trousers >= for package: gnutls-3.3.29-9.el7_6.x86_64
--> Processing Dependency: libnettle.so.4()(64bit) for package: gnutls-3.3.29-9.el7_6.x86_64
--> Processing Dependency: libhogweed.so.2()(64bit) for package: gnutls-3.3.29-9.el7_6.x86_64
--> Running transaction check
---> Package nettle.x86_64 0:2.7.1-9.el7_9 will be installed
---> Package trousers.x86_64 0:0.3.14-2.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

 Package                               Arch                                Version                                       Repository                                     Size
 eos-grpc                              x86_64                              1.56.1-1.el7                                  eos-diopside-dep                              8.6 M
Installing for dependencies:
 c-ares                                x86_64                              1.10.0-3.el7_9.1                              updates                                        78 k
 gnutls                                x86_64                              3.3.29-9.el7_6                                base                                          680 k
 nettle                                x86_64                              2.7.1-9.el7_9                                 updates                                       328 k
 trousers                              x86_64                              0.3.14-2.el7                                  base                                          289 k

Transaction Summary
Install  1 Package (+4 Dependent packages)

Total download size: 10 M
Installed size: 37 M
Is this ok [y/d/N]: n

To work around this dependency issue, I have created a new yum configuration, containing the flag obsoletes=0, and while running the eos-client installation I use this custom yum config instead of the default one.

Hope it helps

Hi Marco,

The proper way to work around this is to version lock eos-grpc to 1.41.0. So if the package manager has upgraded already eos-grpc to 1.56.1 you need to downgrade it.


Thanks Elvin,

I confirm that by installing eos-grpc-1.41.0, adding this package under versionlock, and afterwards installing eos-client, it works.

Have a great day!