EOS client availability for Ubuntu 22.04 Jammy Jellyfish

Hello,

Ubuntu has released new LTS 22.04. Do you think it would be possible to build a client for this release?

Thank you,
Rustem

Hi Rustem,

Yes, we plan to support Ubuntu 22.04. We expect to have a client release ready in the next period.
I will let you know once this is done.

Cheers,
Elvin

Hi,
I’d be very interested in this as well. Do you have an estimate when we’ll have it ?

Hi Ulrich,

For the moment there is no XRootD release for Ubuntu Jammy due to some build issues. Once this is fixed we will also release EOS for Ubuntu Jammy. At this point I can not give you an estimate when this will happen.

Thanks,
Elvin

Hi,
it seems as if xrootd and friends are available now for Jammy Jellyfish. It would be really nice to have eos-client as well if possible! Thanks a lot!
Ulrich

Hi Ulrich,

Indeed xrootd will start to provide builds for jammy, and we are already preparing as well!

Although I believe it will only be available once we tag with xrootd 5.5.0 requirement.

Cheers,
Manuel

Hi, do you have an estimate about when this may become available ? Thanks a lot!

Hi,

Yes, once XRootD 5.5.1 [1] is out it will also provide Ubuntu Jammy packages and then we’ll have an EOS client release also for this distribution. I would say in maximum 2 weeks.

Cheers,
Elvin

[1] Bugfix release 5.5.1 · Issue #1781 · xrootd/xrootd · GitHub

Installation script for jammy (for names starting with ‘o’):

# Add repositories
# The next line is a workaround until jammy will be ready: echo "deb [arch=$(dpkg --print-architecture), signed-by=/usr/share/keyrings/storageci.gpg] http://storage-ci.web.cern.ch/storage-ci/debian/xrootd/ $(lsb_release -cs) release" | sudo tee -a /etc/apt/sources.list.d/cerneos-client.list > /dev/null
echo "deb [arch=$(dpkg --print-architecture), signed-by=/usr/share/keyrings/storageci.gpg] http://storage-ci.web.cern.ch/storage-ci/debian/xrootd/ focal release" | sudo tee -a /etc/apt/sources.list.d/cerneos-client.list > /dev/null
# The next line is a workaround until jammy will be ready: echo "deb [arch=$(dpkg --print-architecture), signed-by=/usr/share/keyrings/storageci.gpg] http://storage-ci.web.cern.ch/storage-ci/debian/eos/citrine/ $(lsb_release -cs) tag" | sudo tee -a /etc/apt/sources.list.d/cerneos-client.list > /dev/null
echo "deb [arch=$(dpkg --print-architecture), signed-by=/usr/share/keyrings/storageci.gpg] http://storage-ci.web.cern.ch/storage-ci/debian/eos/citrine/ focal tag" | sudo tee -a /etc/apt/sources.list.d/cerneos-client.list > /dev/null
#curl -sL http://storage-ci.web.cern.ch/storage-ci/storageci.key | sudo apt-key add -
#curl http://storage-ci.web.cern.ch/storage-ci/storageci.key | gpg --dearmor > /usr/share/keyrings/storageci.gpg

wget -O- http://storage-ci.web.cern.ch/storage-ci/storageci.key |\
gpg --dearmor |\
sudo tee /usr/share/keyrings/storageci.gpg > /dev/null


# Install for Jammy, until it is ready
# FIX libssl1.1 - This is neccesary, because the 22 upgraded to the libssl3
wget http://archive.ubuntu.com/ubuntu/pool/main/o/openssl/libssl1.1_1.1.0g-2ubuntu4_amd64.deb
sudo dpkg -i ./libssl1.1_1.1.0g-2ubuntu4_amd64.deb
# FIX libjsoncpp1
wget http://archive.ubuntu.com/ubuntu/pool/main/libj/libjsoncpp/libjsoncpp1_1.7.4-3.1ubuntu2_amd64.deb
sudo dpkg -i ./libjsoncpp1_1.7.4-3.1ubuntu2_amd64.deb
# FIX libprotobuf17
wget http://archive.ubuntu.com/ubuntu/pool/main/p/protobuf/libprotobuf17_3.6.1.3-2ubuntu5_amd64.deb
sudo dpkg -i ./libprotobuf17_3.6.1.3-2ubuntu5_amd64.deb
# end of jammy fix

# Only do this if there is a problem and read this web first:
# https://askubuntu.com/questions/855474/trying-to-overwrite-which-is-different-from-other-instances-of-package
#sudo apt install -f -o Dpkg::Options::="--force-overwrite" eos-fusex
#sudo apt --fix-broken install
#or maybe: sudo apt --fix-broken install -f -o Dpkg::Options::="--force-overwrite" eos-fusex

sudo apt update
sudo apt install libxrootd-client-dev=4.12.8 libxrdapputils1=4.12.8 libxrdcrypto1=4.12.8 libxrdcryptolite1=4.12.8 libxrdutils2=4.12.8  libxrdxml2=4.12.8 libxrootd-dev=4.12.8 libxrdcl2=4.12.8  libxrdffs2=4.12.8 libxrdposix2=4.12.8 libxrootd-client-dev=4.12.8 xrootd-plugins=4.12.8
sudo apt install eos-fusex

sudo mkdir /etc/eos

# To access openc home
#echo -e '{"name":"home-<initial>","hostport":"eoshome-<initial>.cern.ch","remotemountdir":"/eos/user/<initial>/"}' | sudo tee -a /etc/eos/fuse.home-o.conf
echo -e '{"name":"home-o","hostport":"eoshome-o.cern.ch","remotemountdir":"/eos/user/o/"}' | sudo tee /etc/eos/fuse.home-o.conf

# To access EOS project itself
echo -e '{"name":"project-e","hostport":"eosproject-e.cern.ch","remotemountdir":"/eos/project/e/"}' | sudo tee /etc/eos/fuse.project-e.conf

# Mount
sudo mkdir /eos
sudo eosxd -ofsname=home-o

Thanks for the update! Works for me.

Ubuntu 22.04 for the eos client are now available here:
https://storage-ci.web.cern.ch/storage-ci/debian/eos/diopside/pool/jammy/tag/e/eos/