CERN Accelerating science

EOS Client Availability for Ubuntu 20.04 (Focal Fossa)

Dear All,

I have a naive question. When could we expect DEB packages to become available for Ubuntu 20.04 (Focal Fossa)?

I know that officially only the CERN standard OS-es are supported, but for using EOS from home (during these times…), the Ubuntu support is very much welcome. I just had to install 20.04 on a new machine (for HW reasons), and not having to compile the EOS code by myself for it would certainly make things a lot easier.

If a regular build for this latest Ubuntu LTS release could be added, I would be most thankful. :wink:

Cheers,
Attila

Hi Attila,

For the moment we only provide client packages for Ubuntu Bionic(18.04):
http://storage-ci.web.cern.ch/storage-ci/debian/eos/citrine/pool/bionic/tag/e/eos/

Once XRootD will provide packages for Ubuntu 20.04 then the next EOS release will also provide client packages for Ubuntu 20.04. I will try to remember to update this thread once this happens.

Cheers,
Elvin

Great, but what about the PGP key’s update? Now apt-get update claims the current (fetched from http://storage-ci.web.cern.ch/storage-ci/storageci.key) isn’t valid anymore:

sudo apt-get update
...
Get:16 http://storage-ci.web.cern.ch/storage-ci/debian/xrootd bionic InRelease [8 818 B] 
Get:17 http://storage-ci.web.cern.ch/storage-ci/debian/eos/citrine bionic Release [2 350 B]               
...
Reading package lists... Done                                  
E: The repository 'http://storage-ci.web.cern.ch/storage-ci/debian/eos/citrine bionic Release' is no longer signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Thanks!

Yeah, I also saw that on an Ubuntu 18.04 machine. :frowning: Didn’t want to bring it up at the same time, but I agree, that’s also an issue…

Hi,

There seems to be some basic problem with the hiredis package on Ubuntu 20.04 and the compilation of EOS fails for this reason. Once this will be fixed we’ll give it one more shot.

root@5965b6a9b30d:/tmp# cat main.cc
# Contents of main.cc
#include "hiredis/adapters/libevent.h"

int main(int argc, char* argv[])
{
  auto ctx = redisConnect("dummy", 8888);
  return 0;

}

root@5965b6a9b30d:/tmp# gcc  main.cc -lhiredis -levent
/usr/bin/ld: /tmp/ccnpVOGH.o: in function `redisLibeventAttach(redisAsyncContext*, event_base*)`:
main.cc:(.text+0x19f): undefined reference to `hi_malloc(unsigned long)`
collect2: error: ld returned 1 exit status

root@5965b6a9b30d:/tmp# dpkg -l | grep hiredis
ii  libhiredis-dev:amd64             0.14.0-6                          amd64        minimalistic C client library for Redis (development files)
ii  libhiredis0.14:amd64             0.14.0-6                          amd64        minimalistic C client library for Redis
ii  libhiredis0.14-dbgsym:amd64      0.14.0-6                          amd64        debug symbols for libhiredis0.14

If xrootd is enough for what you need to do, then the packages for Ubuntu 20.04 are now available here: http://storage-ci.web.cern.ch/storage-ci/debian/xrootd/pool/focal/

We’ll also look into the PGP key issue, thanks for reporting.

Cheers,
Elvin

Hi,

the issue with the PGP key should be now solved, but please feel free to inform us if you still experience any issue with that.

Thanks again for reporting,
Cheers,
Fabio

This issue get solved now, thanks! But the new eos (4.8.8) didn’t find a shared library:

$ eos
eos: error while loading shared libraries: libXrdPosix.so.2: cannot open shared object file: No such file or directory

It likely could be fixed just by installing an appropriate package but apt-get didn’t report any dependency issues while installing the updated eos client.

Thanks!

Hi Timur,

You need to install the xrootd 4.12.3 Ubuntu package rather than version 5.0.0. We’ll have to enforce the version of xrootd to be used also for the Ubuntu packages just as we do in CentOS7. For the moment we were not doing this since we were happy with any of the latest XRootD release. Not anymore since a couple of days when XRootD 5 was released.

Cheers,
Elvin

Downgraded all xroot packages to 4.12.3, and it’s running now. Thanks!