EOS 5.2 on Alma Linux 9.3 fresh install


I’ve just installed eos 5.2 on Alma Linux 9.3 as a server and client, but before starting using it I’m facing a permission denied when issuing the command:

eos space define default
error: errc=3010 msg=“[ERROR] Error response: permission denied”

I think that it is a dumb question, but anyway, couldn’t find a solution yet.


Hi Wander,

This usually means that you don’t have an admin role when connecting to EOS. The easiest way to see who you are authenticated as by the server, is to run the following command:
eos whoami

Then probably you want to run your eos commands as root since then you can pick up the sss key and be authenticated as an admin on the EOS instance. It’s important to also enable sss mapping on you instance using the following command eos vid enable sss.


Hello Elvin,

Thanks for your attention.
Looks like eos is being authenticated as nobody (99), even being started as root:

EOS Console [root://] |/> whoami
Virtual Identity: uid=99 (99) gid=99 (99) [authz:sss] host=silix domain=localdomain

I don’t have any eos_user user on my /etc/passwd and don’t know if I must create one, since I didn’t find any instructions to do that.

I’m also confused about hostnames and networks, since the mgm log file is showing this:

=====> mgmofs.hostname: localhost.܈.
=====> mgmofs.hostpref: localhost
231122 08:36:08 122161 MgmOfs_Config: Unable to convert hostname to IP address: Name or service not known; no such file or directory
------ xroot protocol initialization completed.
------ eos-mgm mgm@localhost:1094 initialization completed.
231122 08:37:37 122332 XrootdXeq: root.123283:27@silix pvt IP46 login as eosnobody

My Internet connection comes from Wi-Fi DHCP ( but I’m trying to use a local network ( where I have other machines planed to be used as FST nodes in my initial tests.

The “eos vid anable sss” do not work at the moment:

[root@silix ~]# eos vid enable sss
error: errc=3010 msg=“[ERROR] Error response: permission denied” (errc=3010) (Unknown error 3010)
[root@silix ~]#


Hi Wander,

I think the root of your problems is the fact that the MGM can not properly get the hostname which needs to be FQDN for the machine it’s running on. Check what is the output of the hostname -A command and see if it matches your expectations, but clearly the xrootd process can not get a proper hostname. What is does underneath is to simply call the C function gethostname, so this should be easy to debug.