EO5 upgrade broken, no filesystems

Hi! So after going through some work to upgrade and hitting some weird problems like:

1. you really need to uninstall EVERYTHING eos related and then re-install fresh 
2. you really need both system(epel) xrootd and eos-xrootd as a component from FstOfs require /usr/bin/xrdcp
220526 18:02:26 14436 FstOfs_Run: Unable to set up /usr/bin/xrdcp; no such file or directory

3. you will need to change the geotag if you used to have a the simplest 1 string one (i used to have ::ISS and after looking into code i changed it to ISS::ALICE to make fst to start)

and now i no longer have any filesystems, and a node ls shows the online nodes with no fs
@esindril do you have any idea on this?

Thanks a lot!

the problem was solved, thanks to @acontesc which pointed to me the following link:

seems that at some point in EOS4 there was added the possibility of storing the mgm configuration in quarkdb, and starting with EOS5 that become the only possibility of storing the configuration. following the above link and doing the procedure with eos-config-inspect worked (but not with eos config export)