Emacs file save permission error on fusex, fix with EOS_ALLOW_RAIN_RWM?

When opening a file on a fusex mount, when trying to save multiple times, we see in the Emacs editor:

Write error: Permission denied, /eos/vbc/user/user.name/test.txt

On the mgm we see in the log:

200929 16:43:47 time=1601390627.440278 func=Emsg                     level=ERROR logid=2e74edc8-0262-11eb-ab38-3868dd28d0c0 unit=mgm@mgm-1.eos.grid.vbc.ac.at:1094 tid=00007f54c23fe700 source=XrdMgmOfsFile:3094             tident=AAAAAAAw.28068:775@cbe.vbc.ac.at sec=sss   uid=12345 gid=12345 name=user.name geo="vbc" Unable to update RAIN layout file - you have to be a priviledged user for updates ; Operation not permitted

The error seems to be coming from mgm, here

There is an env variable, EOS_ALLOW_RAIN_RWM that would avoid this error, but I could not find any information about this one. Is it safe to turn this on (on mgm), are there other side effects to consider?
Or is there another solution like fusex settings?

I’ve tried to reproduce this on the lxplus EOS homes, there it worked for me, so I assume this is also used there.