Drainperiod setting

Hi all,

I have issue with eos drain period. I did set it for 24h (86400s) for default space:
[root@a-se ~]# eos space status default

drainperiod := 86400
filearchivedgc := off
geobalancer := off
geobalancer.ntx := 10
geobalancer.threshold := 5
graceperiod := 86400

Unfortunately when I start drain the time of draining is 1h (3600s).
What can be an issue?

eos fs ls -d

│host │port│ id│ path│ drainstatus│ progress│ files│ bytes-left│ timeleft│ retry│ failed│
a-fst1.grid.icm.edu.pl 1095 3 /alice/gpfs2 draining 0 440.91 K 173.25 GB 3455 0 0

FS no. 3 belongs to default space:

eos fs ls

│host │port│ id│ path│ schedgroup│ geotag│ boot│ configstatus│ drainstatus│ active│ health│

a-fst1.grid.icm.edu.pl 1095 3 /alice/gpfs2 default.2 ALICE::ICM::EOS booted drain draining online no smartctl


Hi Karol,

The space settings will only affect newly added filesystems.
In order to change the current value on all filesystems in a space, you could use:

eos space config <space> fs.drainperiod=<drain_period_in_seconds>

Hope this helps.


Thank you. It worked.