Don't use XRootD 4.9 on EOS server-side

This is just a warning,
XRootD 4.9. has several problems to be used with EOS, in particular it breaks all FUSE access with eosd and eosxd. So, don’t install it on FSTs and MGMs until further notice.

Cheers Andreas.