Can't connect a separate FST node

I’ve set up 3 master nodes with EOS 5.2.5 on Alma8 nodes, containing QDB, MGM, MQ services. I’ve got QDB cluster running with a leader and MGM with a master promoted, so it’s time to add the first FST node.

On FST node I’ve placed the same /etc/eos.keytab and /etc/eos/fuse.sss.keytab files, edited “QDB_HOST=master1.eos” and “ root://master1.eos:1097//eos/” options in /etc/eos/config/fst/fst and started eos5-fst@fst service.

Master(QDB, MGM, MQ) node still doesn’t see the node.
Even when I run “eosfstregister -r master1.eos /data/fst/ default:6” against pre-created dirs on FST node, I’m getting the following error on master:

240117 09:04:11 INFO  [00099/00099]                - ::IdMap            sec.prot=sss"eosnobody""fst5.eos" sec.vorg="" sec.grps="eosnobody" sec.role="""""" sec.tident="root.171468:287@fst5" vid.uid=99 vid.gid=99 sudo=0 gateway=0 
240117 09:04:11 INFO  [00099/00099]        eosnobody ::open             op=read path=/proc/admin/ info=mgm.cmd.proto=MigSJhokNTQ2ZTc3ZGItNWY0YS00NjgwLWI1ZDEtNTViOTZiMjNkZjcx 
240117 09:04:11 ERROR [00099/00099]        eosnobody ::Emsg             Unable to execute proc command - you don't have the requested permissions for that operation (2) /proc/admin/; Operation not permitted 

On master:

[root@master1 ~]# eos whoami
Virtual Identity: uid=0 (0,3,99) gid=0 (0,4,99) [authz:sss] sudo* host=localhost domain=localdomain
[root@master1 ~]# eos vid enable sss
success: set vid [  eos.rgid=0 eos.ruid=0 mgm.cmd=vid mgm.subcmd=set mgm.vid.auth=sss mgm.vid.cmd=map mgm.vid.gid=0 mgm.vid.key=<key> mgm.vid.pattern=<pwd> mgm.vid.uid=0 ]

Meanwhile on FST:

[root@fst5 ~]# eosfstregister -r master1.eos /data/fst/ default:6
/data/fst/01 : uuid=bf9308c0-f557-4e7e-b396-5464a3f7934b fsid=undef
error: errc=3010 msg="[ERROR] Error response: permission denied"
error: errc=3010 msg="[ERROR] Error response: permission denied"
[root@fst5 ~]# eos whoami
error: MGM root://localhost not online/reachable

Not sure why FST doesn’t see MGM as master1.eos, as long as I’ve got “QDB_HOST=master1.eos” and “ root://master1.eos:1097//eos/” options in /etc/eos/config/fst/fst

You should run on the MGM:

eos node set fst.eos:1095 on

Then start the FST, you should see it on the MGM
eos node ls

If you don’t see it, verify the the entry for daemon in /etc/eos.keytab is the same on FST and MGM node. If yes, remove the eosnfsnobody entry from /etc/eos.keytab and try again to start the FST and register.

Thanks much, @apeters !
I did:

[root@master1 ~]# eos node set fst5.eos:1095 on
info: creating node '/eos/fst5.eos:1095/fst'
[root@fst5 ~]# systemctl restart eos5-fst@fst
[root@master1 ~]# eos node ls
│type      │                        hostport│          geotag│    status│   activated│  heartbeatdelta│ nofs│
 nodesview                     fst5.eos:1095       local::geo     online           on                1     0