Moving active, non-empty, fsids between sched groups

I wish to move existing, active fsids between scheduling groups.

Attempting to move a non-empty fsid results in “filesystem is not empty or not active”.

Is there a flag to force this, or can schedgroup=(group) memberships safely be manually edited in default.eoscf config file directly?

In the past to move an fsid which had been migrated between FSTs we have edited default.eoscf, can the same manual edit process be used here or are there other factors which need considered?


Hi Pete,

It is not safe to move a file system like this. You should first drain them and then assign them to the desired scheduling group - the fs mv operation will do some extra checks.
Forcing this by modifying the config file is not a good idea as you might mess up the failure domains and have two disks from the same machine in the same scheduling group. If the machine dies then you lose both replicas.


I think for Pete’s use case it makes sense to have a move option, because he is not using replication.
There are some other cases where you might want to force a move knowingly. So I think, it would be good to have a ‘–devil’ option to do it :slight_smile:

Thanks Elvin and Andreas.

As Andreas noted, we are moving to a single disk fsid layout wherein ALICE will handle replication between sites, we won’t have need for multiple local copies and multiple sched groups – and we want to avoid draining lots of data locally if such is it not really needed.

We will thus proceed with moving the fsids into one scheduling group by manually changing schedgroup= in the config file.

If there are any checks recommended to perform after reassigning the fsids please let us know, and thanks for the assistance.